X
RSS YouTube LinkedIn Twitter Facebook

Search




Post new topic Reply to topic   [ 2 posts ] 
Author Message
91
PostPosted: Fri Jun 01, 2012 12:43 pm 
User avatar
Member++
Joined: Tue May 01, 2012 1:58 pm
Posts: 21
Hello!
First, I would like to make sure that the XTAG-2 interface is compatible with the XS1-L1 48 package, because (1) is stating that
Quote:
The XTAG-2 is based on a single XS1-L1 device in a 64LQFP package.


Assuming that the answer for the above is positive:
XS1-L1 package does not contain a 'debug' port. Therefore, I am looking for the correct way to terminate the incoming 'debug' line from the header to the board. This line is defined as bidirectional in (1). Combining the schematics of XTAG-2 (2) and audio RD (3), it seems that unused incoming port are just left not-connected. Can someone verify this?

(1)https://www.xmos.com/download/public/XTAG-2-Hardware-Manual%281.0%29.pdf.
(2)https://www.xmos.com/download/private/XTAG-Schematics%281.0.4%29.pdf
(3)https://www.xmos.com/download/public/USB-Audio-2.0-Ref-Design-XS1-L1-Hardware-Manual-%281v1%29%281.0%29.pdf

Thanks and have a good weekend! Elad.


Top
Offline Profile View all posts by this user  
 
2524
PostPosted: Fri Jun 01, 2012 12:49 pm 
User avatar
XCore Moderator
Joined: Thu Dec 10, 2009 6:56 pm
Posts: 588
Hello eladmmor,

The XTAG2 itself is based on a XS1-L1-64 but it can be used to debug all XMOS devices with JTAG.

If the target device does not have a debug pin, you can leave the debug pin on the XTAG2 header unconnected.

Please also note that you do not need to connect the UART and XMOS Link lines if you do not want to use it. (The XMOS Link on the XTAG2 adapter cannot be used to connect to XS1-G devices)


Top
Offline Profile View all posts by this user  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic   [ 2 posts ] 


Who is online

Users browsing this forum: No registered users and 3 guests



Search for:
Jump to: