USB Audio 2.0 support coming to Windows 10 from Microsoft

Off topic discussions that do not fit into any of the above can go here. Please keep it clean and respectful.
User avatar
akp
XCore Addict
Posts: 209
Joined: Thu Nov 26, 2015 11:47 pm

Re: USB Audio 2.0 support coming to Windows 10 from Microsoft

Postby akp » Wed Jun 27, 2018 4:16 pm

They monitor the forums, don't worry, they know.
MaximLiadov
Member++
Posts: 23
Joined: Mon Apr 16, 2018 9:14 am

Postby MaximLiadov » Fri Jun 29, 2018 12:36 pm

Ok. We are looking forward to any official XMOS comment on this topic. Do they have any plan to make official firmware to be 100% compatible with W10 out-of-the-box driver or not. I don't think we are capable to do this by our own knowledge.
bearcat
Respected Member
Posts: 270
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Tue Jul 03, 2018 8:17 am

(Edited since no reply yet with new data. I had microphone privacy turned on, silly me. And appears a poor USB cable.)

I worked a little bit here... Ill keep the politics out for now.

The Windows UAC2 native driver only supports explicit feedback per the website.
1 - Setting no inputs selects explicit feedback
2 - Enable inputs and add this to customdefines.h: #define UAC_FORCE_FEEDBACK_EP

Inputs can be enabled and still operate as output device.

The UAC2 driver does not support setting a clock selector. The website says they will ignore it. So if you have SPDIF, ADAT, or ? you will need another means to select clocks.

I got the older L1 reference board and latest software to connect and play with explicit feedback and inputs enabled. It operated fine on both inputs and outputs. A loopback showed correct audio.

There if a post online of a Teac dac operating with the UAC2.

I am testing/retesting with my custom board.

So, it appears item 2 above should get things working with the Windows native UAC2 driver with inputs and outputs working. I will offer an update later after more testing.
bearcat
Respected Member
Posts: 270
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Thu Jul 05, 2018 7:00 am

I started a new thread for my summary. See:

viewtopic.php?f=8&t=6806
tiasuccess
Newbie
Posts: 1
Joined: Fri Nov 02, 2018 3:45 pm

Postby tiasuccess » Fri Nov 02, 2018 3:47 pm

akp wrote:Just checking if you referred to https://docs.microsoft.com/en-us/window ... io-drivers
If not, you may need to slog through that and make sure everything works out. It seems like Windows is picky, as usual. e.g. you will need to use explicit feedback apparently.




Thanks for the link.

Who is online

Users browsing this forum: No registered users and 10 guests