Enable the DFU function

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
qwerasdfzxcv
Member++
Posts: 20
Joined: Thu Oct 19, 2017 1:44 pm

Enable the DFU function

Postby qwerasdfzxcv » Thu Oct 19, 2017 1:59 pm

Hello, I would like to ask some questions about DFU.
The development board I'm using is XVF-3100.I want to use its DFU function.But my tool TUSBAudio's Status of USB Audio Device displays No devices connected.
My computer shows that my driver has always been XMOS Microphone Array Control.And I tried the method of DFU loader for XMOS USB AUDIO devices.
My endpoint0 () function has always been a syntax error.I don't know if it's related to this.
What actions should I perform to successfully use DFU functionality?
I look forward to your reply.
User avatar
infiniteimprobability
XCore Expert
Posts: 875
Joined: Thu May 27, 2010 10:08 am
Contact:

Postby infiniteimprobability » Fri Oct 20, 2017 10:58 am

Hi and welcome to xcore.

DFU is enabled by default in the firmware and so the DFU interface should be present (for example if you browse the descriptors).

Does it work on the stock firmware? We test for this explicitly so it should..

Does it stream audio OK?

"My endpoint0 () function has always been a syntax error.I don't know if it's related to this.".
You don't say what the error is or whether it caused a build fail or not. Can you provide more info?
qwerasdfzxcv
Member++
Posts: 20
Joined: Thu Oct 19, 2017 1:44 pm

Postby qwerasdfzxcv » Sun Oct 22, 2017 7:35 am

Thank you very much for your reply.
I hope you can help me with other problems.
I have burned the app_vf_spk_base_1i0_cir_1i0_cir43_i2s_only_16khz. Xe, but there is no audio driver, and I can't output the sound. What is the reason?
User avatar
infiniteimprobability
XCore Expert
Posts: 875
Joined: Thu May 27, 2010 10:08 am
Contact:

Postby infiniteimprobability » Mon Oct 23, 2017 10:58 am

Are you connected via I2S to an audio host?

If so app_vf_spk_base_1i0_cir_1i0_cir43_i2s_only_16khz is fine. If not (and you want USB audio using windows/driverless audio class 1) please use a build such as:

1i1o2_cir43

Did you follow https://www.xmos.com/download/private/s ... rc5%29.pdf?

Also, what about:

"My endpoint0 () function has always been a syntax error.I don't know if it's related to this.".
You don't say what the error is or whether it caused a build fail or not. Can you provide more info?

Return to “Development Tools and Programming”

Who is online

Users browsing this forum: No registered users and 25 guests