X200 multichannel FW on X200 explorer

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
User avatar
akp
XCore Addict
Posts: 196
Joined: Thu Nov 26, 2015 11:47 pm

Re: X200 multichannel FW on X200 explorer

Postby akp » Sat Mar 17, 2018 10:11 pm

Hi, Sorry I can't comment on this kit as I use the MC audio board. Good luck!
User avatar
Dodotronic
Member++
Posts: 17
Joined: Fri Dec 20, 2013 2:27 pm

Postby Dodotronic » Sun Mar 18, 2018 12:44 am

Probably just cause you are using the mc board ....
Are the lrclk and bclk generated from mclk in?
If so just with only the mclr in I should have the other signals?
Thanks
Iv
User avatar
akp
XCore Addict
Posts: 196
Joined: Thu Nov 26, 2015 11:47 pm

Postby akp » Sun Mar 18, 2018 1:32 pm

Follow the advice mon2 gave you and get your clocks all working correctly. Once you have that working then, yes, the bclk and lrclk are generated from mclk in. mclk generates the bclk, and the lrclk is generated by the bclk essentially. If you could use the MC audio board for your development it might be easier because the software already runs, and you can disconnect the onboard ADC from the MCU. Can't really give any more help.
User avatar
Dodotronic
Member++
Posts: 17
Joined: Fri Dec 20, 2013 2:27 pm

Postby Dodotronic » Sun Mar 18, 2018 6:31 pm

you are right
just taken the MC audio board
Thanks!
Iv
User avatar
Dodotronic
Member++
Posts: 17
Joined: Fri Dec 20, 2013 2:27 pm

Postby Dodotronic » Fri Mar 23, 2018 11:26 am

I'm working now on the MC board. It seems to run smoothly.
There are something that I still don't understand:
- where can I change the number of SDO pins used? as well as bit lenght per frame?
- how to set 16 bit instead of 24 and so to stram only 4 channels?

Who is online

Users browsing this forum: No registered users and 28 guests