xTimeComposer becomes slow when not connected to Internet

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
User avatar
BEBDigitalAudio
Experienced Member
Posts: 76
Joined: Thu Nov 11, 2010 7:45 pm

xTimeComposer becomes slow when not connected to Internet

Postby BEBDigitalAudio » Wed Apr 18, 2018 1:32 pm

Hi everybody,

I am facing a very strange problem with xTimeComposer 14.3.2 Community on Windows: the compiler becomes awfully slow when the machine is not connected to Internet.
The project I am working on is quite big (around 100 source files to compile, with Ethernet, I2C, etc... libraries)

When I compile the project with the computer connected to Internet, the project takes 55s to compile completely (after a clean to force a full compilation). If the computer is not connected to Internet, the same compilation process takes at least 9 minutes!!!
Even worse : if the computer NIC is connected to the target I am working on, xTimeComposer can freeze completely : it stays blocked at following step

Checking build modules
Using build modules: lib_ethernet(3.3.0) lib_gpio(1.1.0) lib_locks(2.0.3) lib_logging(2.1.0) lib_xassert(3.0.0)

and does not even start the Analysis.
Apparently, when xTimeComposer sees an active network connection, it wants absolutely to connect to the Internet, even if this connection does not go to the web...

Anybody has an idea about the reason the compiler is acting like this? And is there any workaround to say to xTimeComposer not to try to reach the Internet ?

Thanks
Benoit
User avatar
andrewxcav
Active Member
Posts: 61
Joined: Wed Feb 17, 2016 5:10 pm
Contact:

Postby andrewxcav » Tue Jun 12, 2018 12:57 pm

The only things it uses the internet for are logging in, design examples, and importing libraries/modules (which only happens if they aren't found at build time). To avoid logging in you can copy your tools key from your xmos.com account into xTimeComposer.
User avatar
BEBDigitalAudio
Experienced Member
Posts: 76
Joined: Thu Nov 11, 2010 7:45 pm

Postby BEBDigitalAudio » Fri Nov 30, 2018 7:46 am

Hi all,
I finally found the cause of the slowing down problem : Kaspersky antivirus !!!
For an unknown reason, xTimeComposer interacts very badly with this antivirus. I found that Kaspersky keeps opening and closing Internet connections for EACH file being compiled. And apparently, xTimeComposer waits for a feedback from the antivirus which acts as a proxy.
I have simply desinstalled Kaspersky. Results speak by themselves : a project which took 6 minutes (!!!!) to be compiled when Kaspersky is in the game takes now 41 secondes for a complete build.
User avatar
andrewxcav
Active Member
Posts: 61
Joined: Wed Feb 17, 2016 5:10 pm
Contact:

Postby andrewxcav » Fri Nov 30, 2018 3:24 pm

That's rough. I can recall having issues with basically an IDE and basically any AV in the past!

Who is online

Users browsing this forum: No registered users and 36 guests