How to check active #defines in XTimeComposer Editor

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
maqu67
Member++
Posts: 16
Joined: Tue Jan 23, 2018 3:26 pm

How to check active #defines in XTimeComposer Editor

Postby maqu67 » Sat Aug 11, 2018 11:12 am

Hello,

I'm working on "sw_usb_audio-[sw]_6.15.2rc1" with XTimeComposer.

In files like "customdefines.h", "devicedefines.h" and in the Makefile I've some "#define" like MIXER, SPIDF_RX, ADAT_RX ... and so on.
I'd like to know if after the project compilation there is any manner to see in the editor which "define" have been activated and which not,
perhaps looking the background colors of the instructions.

I'd like to see which code sections are active and which not for the particular configuration I've selected.

Thanks a lor in advance

Best Regards

Massimiliano
User avatar
mon2
XCore Legend
Posts: 1285
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Sat Aug 11, 2018 1:57 pm

xTimeComposer is built upon Eclipse so the color schemes and solutions for Eclipse should work in the same.

Try the following and post your results:

https://stackoverflow.com/questions/109 ... in-eclipse
Attachments
xmos_eclipse_color.png
(75.26 KiB) Not downloaded yet
xmos_eclipse_color.png
(75.26 KiB) Not downloaded yet
maqu67
Member++
Posts: 16
Joined: Tue Jan 23, 2018 3:26 pm

Postby maqu67 » Sat Aug 11, 2018 9:18 pm

Thanks a lot

Massimiliano

Who is online

Users browsing this forum: No registered users and 213 guests