Troubles running xTIMEcomposer 14.3.3

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
mkurc
New User
Posts: 2
Joined: Tue Oct 02, 2018 8:20 am

Troubles running xTIMEcomposer 14.3.3

Postby mkurc » Tue Oct 02, 2018 8:35 am

Hello,

I am trying to run the latest xTIMEcomposer 14.3.3 and i simply cannot make it work:

I have downloaded the Linux 64-bit version and tried to run it on Ubuntu 16.04 LTS (64-bit). It appears that the app is missing most of its fonts (see the screenshot file Linux.png). I have tried with both open JRE and oracle JRE (both java v8) and the result is the same. The app actually works but with no fonts it is unusable.
Linux.png
(10.69 KiB) Not downloaded yet
Linux.png
(10.69 KiB) Not downloaded yet


When done with Linux I have tried to run the windows version on Windows 10 and Windows 7 (win 7 inside a VM). Both systems are 64-bit. Under Windows the application simply does not run. See the screenshot Windows.png, there is a large window with java errors and so on. The java version is "8 update 181 (build 1.8.0_181-b13).
Windows.png
(30.42 KiB) Not downloaded yet
Windows.png
(30.42 KiB) Not downloaded yet


What else can I do? Any suggestions?

Best regards,
Maciej
User avatar
mon2
XCore Legend
Posts: 1254
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Oct 02, 2018 12:19 pm

User avatar
mon2
XCore Legend
Posts: 1254
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Oct 02, 2018 1:09 pm

On the raised Windows error, there has been a long time requirement that the XMOS toolchain requires the installation of a 32 bit JAVA runtime environment, even if your OS is 64 bit.

Please install the 32 bit version of the same JAVA s/w and post your results. You do not need to remove the 64 bit JAVA s/w as both the 32 and 64 bit releases can co-exist in the same box.
bearcat
Respected Member
Posts: 270
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Wed Oct 03, 2018 4:31 am

I am running on Ubuntu 18.04 64 bit just fine. Here are my steps:

sudo apt-get install openjdk-8-jre
sudo tar -xf ./xTIMEcomposer-Community_14-Linux64-Installer_Community_14.3.3.tgz -C /opt
Wrong character set. Search /opt/XMOS folder for libpangoft2-1.0.so.0. Delete it.
cd /opt/XMOS/xTIMEcomposer/Community_14.3.3/scripts
sudo ./setup_xmos_devices.sh
sudo ./check_xmos_devices.sh

Create new file xtimecomposer.sh in home:
#!/bin/bash

cd /opt/XMOS/xTIMEcomposer/Community_14.3.3
source SetEnv
export JAVA_HOME="/usr/lib/jvm/java-1.8.0-openjdk-amd64"
PATH=${JAVA_HOME}/bin:$PATH
xtimecomposer

Change permissions to execute. Create shortcut to this file.
Last edited by bearcat on Thu Oct 04, 2018 6:06 pm, edited 1 time in total.
mkurc
New User
Posts: 2
Joined: Tue Oct 02, 2018 8:20 am

Postby mkurc » Wed Oct 03, 2018 3:10 pm

I have tried both solutions (Linux and Windows) and both of them work! Thanks!

Best regards,
Maciej

Who is online

Users browsing this forum: KanatsG and 34 guests