xCORE-200 eXplorerKIT: Unable to run examples

New to XMOS and XCore? Get started here.
User avatar
MisterHemi
Junior Member
Posts: 5
Joined: Tue Jun 19, 2018 1:21 am

xCORE-200 eXplorerKIT: Unable to run examples

Postby MisterHemi » Tue Jun 19, 2018 1:48 am

Hello everyone,

I just got an xCORE-200 eXplorer board. I have xTIMEcomposer (v. 14.3.3) installed on Mac OS.

I downloaded AN00155_explorer_gpio and lib_gpio (v. 1.1.0). I'm not sure if it has to be added/installed to AN00155 before building, etc.

I have tried to build it (by clicking on the Hammer icon) and it seem fine. The build console shows:

Code: Select all

16:14:42 **** Incremental Build of configuration Default for project AN00155_explorer_gpio ****
xmake CONFIG=Default all
Checking build modules
Using build modules: lib_gpio(1.1.0) lib_xassert(3.0.0)
xmake[1]: `bin//app_simple_gpio_demo.xe' is up to date.
Build Complete

16:14:43 Build Finished (took 697ms)


However when I try to run it on my board (by clicking the Lightning Bolt icon) I get the following message:
https://www.icloud.com/iclouddrive/0gjKqbKZNQAsE7iUEHZV7nrBw#ProblemOccurred.jpeg

I wish there were a detailed step by step tutorial explaining how to go from connecting the board to running a demo project.
If they make such a guide or tutorial they should pin it to the top of the forum so the question is asked less often.
Last edited by MisterHemi on Thu Jun 21, 2018 7:21 pm, edited 1 time in total.
User avatar
mon2
XCore Legend
Posts: 1133
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Jun 19, 2018 10:52 am

Attachments
xmos1.png
xmos1.png (28.89 KiB) Viewed 584 times
xmos1.png
xmos1.png (28.89 KiB) Viewed 584 times
xmos2.png
xmos2.png (13.06 KiB) Viewed 584 times
xmos2.png
xmos2.png (13.06 KiB) Viewed 584 times
User avatar
mon2
XCore Legend
Posts: 1133
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Jun 19, 2018 10:56 am

Attachments
xmos3.png
(58.63 KiB) Not downloaded yet
xmos3.png
(58.63 KiB) Not downloaded yet
User avatar
mon2
XCore Legend
Posts: 1133
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Jun 19, 2018 10:56 am

Attachments
xmos4.png
xmos4.png (7.06 KiB) Viewed 584 times
xmos4.png
xmos4.png (7.06 KiB) Viewed 584 times
User avatar
mon2
XCore Legend
Posts: 1133
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Jun 19, 2018 10:56 am

Attachments
xmos5.png
xmos5.png (45.25 KiB) Viewed 584 times
xmos5.png
xmos5.png (45.25 KiB) Viewed 584 times
User avatar
mon2
XCore Legend
Posts: 1133
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Jun 19, 2018 10:57 am

Attachments
xmos7.png
(42.69 KiB) Not downloaded yet
xmos7.png
(42.69 KiB) Not downloaded yet
User avatar
mon2
XCore Legend
Posts: 1133
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Jun 19, 2018 10:58 am

Attachments
xmos8.png
(42.56 KiB) Not downloaded yet
xmos8.png
(42.56 KiB) Not downloaded yet
User avatar
mon2
XCore Legend
Posts: 1133
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Jun 19, 2018 10:58 am

Attachments
xmos9.png
xmos9.png (20.41 KiB) Viewed 584 times
xmos9.png
xmos9.png (20.41 KiB) Viewed 584 times
User avatar
mon2
XCore Legend
Posts: 1133
Joined: Thu Jun 10, 2010 11:43 am
Contact:

Postby mon2 » Tue Jun 19, 2018 10:58 am

Attachments
xmos10.png
xmos10.png (15.48 KiB) Viewed 584 times
xmos10.png
xmos10.png (15.48 KiB) Viewed 584 times
User avatar
MisterHemi
Junior Member
Posts: 5
Joined: Tue Jun 19, 2018 1:21 am

Postby MisterHemi » Tue Jun 19, 2018 11:40 am

Ok. I believe everything was downloaded before but I tried again following the steps shown in the screenshots.

It seems some header files are missing as well.

Here's what I did:

Image

Image

Image

Image

Image

It seems the images aren't being displayed on the forum, sigh.
Here are links to the images:
https://ibb.co/fkamCy

https://ibb.co/cYd6Cy

https://ibb.co/eLpeXy

https://ibb.co/hTAa5J

https://ibb.co/j9EPzd
Last edited by MisterHemi on Tue Jun 19, 2018 12:00 pm, edited 3 times in total.

Who is online

Users browsing this forum: No registered users and 11 guests