Problem with StartKit.xn and ADC since xTimeComposer 14.3.0

All technical discussions and projects around startKIT
JoeD
Junior Member
Posts: 7
Joined: Tue Aug 12, 2014 3:50 pm

Problem with StartKit.xn and ADC since xTimeComposer 14.3.0

Postby JoeD » Wed Oct 11, 2017 6:50 am

Hi.

Is it possible that the StartKit.xn File changed since xTimeComposer 14.3.0?
It seems the definitions for the ADC Part are gone.
The "AN00177_startKIT_adc_demo" is complaining about a possibly missing prototype.

Code: Select all

Description   Resource   Path   Location   Type
unknown function identifier `startkit_adc' (possibly missing prototype?)   main.xc   /AN00177_startKIT_adc_demo/src   line 93   C/C++ Problem


Does anybody know if this behavior is intended?
Is there a different way to access the ADC on the StartKit?

Thank you
JoeD
astewart
Posts: 6
Joined: Mon Sep 19, 2016 4:50 pm

Postby astewart » Wed Oct 11, 2017 2:08 pm

Hi JoeD,

It doesn't look like the STARTKIT.xn file has changed recently. I've confirmed that the versions installed with 14.2.4, 14.3.0 and 14.3.2 are identical.
The AN00177_startKIT_adc_demo example builds for me straight out of the box in both 14.3.0 and 14.3.2. Have you tried pulling the example directly from the example browser in a new workspace?

Have you modified your XN file or main.xc manually? If so, can you post the updated code. I've attached my STARTKIT.xn file (which has the appropriate descriptors for the startkit_adc service).

--Aaron
Attachments
STARTKIT.xn
Target for startKIT
(2.52 KiB) Downloaded 4 times
STARTKIT.xn
Target for startKIT
(2.52 KiB) Downloaded 4 times
JoeD
Junior Member
Posts: 7
Joined: Tue Aug 12, 2014 3:50 pm

Postby JoeD » Fri Oct 13, 2017 6:28 am

HI Aaron,

thank you for your investigation.

Attached you find the File the xTimeComposer is linking to in newly created projects.
A bit strange, the file is on a Network Drive (H:\.xmos\targets\STARTKIT). But I guess it is because the Network Drive is a "Home"-Drive.
The File was created 02.03.2017.
Older Projects had a Hardcopy of the Xn-File which is identical to the one you posted.

I don't know why this file could have changed.
Or why the recent installation of xTimeComposer 14.3.2 didn't overwrite the file but keeping the link to it.

I'm a bit puzzled.

Best regards
JoeD
Attachments
STARTKIT.xn
(1.79 KiB) Downloaded 2 times
STARTKIT.xn
(1.79 KiB) Downloaded 2 times

Return to “startKIT”

Who is online

Users browsing this forum: No registered users and 3 guests