Driver USB XMOS for linux

Non-technical related questions should go here.
Eaque483
New User
Posts: 3
Joined: Wed Oct 11, 2017 10:38 am

Driver USB XMOS for linux

Postby Eaque483 » Wed Oct 11, 2017 10:42 am

Hi !
I have bought an amplifier from advance acoustic which need a XMOS driver to run with a computer.
However the XMOS Driver to download on their website isn't working on linux ( https://advance-acoustic.com/fr/element ... 118-x-i-75 ).
I just wanted to know if XMOS was providing a driver that will allow my linux computer to run this ampli.

Thanks a lot !
Eaque
User avatar
Ross
XCore Expert
Posts: 761
Joined: Thu Dec 10, 2009 9:20 pm

Postby Ross » Wed Oct 11, 2017 10:53 am

Hi,

This forum is for people trying to build devices and program Xmos chips - you should contact the supplier of your amplifier for product support.

Its hard for us to know what changes they have made in the software - but it should generally "just work"
Eaque483
New User
Posts: 3
Joined: Wed Oct 11, 2017 10:38 am

Postby Eaque483 » Wed Oct 11, 2017 10:59 am

Hi Ross !
Thank you for answering me, I'm pretty sorry, i thought i was at the right place ! The problem is that i have contacted the supplier but they told me to contact XMOS - which didn't replied me that's why i tried the forum..when you mean "just work" you mean that it should just work without the driver on linux ?
User avatar
infiniteimprobability
XCore Expert
Posts: 874
Joined: Thu May 27, 2010 10:08 am
Contact:

Postby infiniteimprobability » Fri Oct 13, 2017 11:06 am

I am afraid you really need to approach Advance Acoustic. Palming you off to their supplier when you have spent a lot of money on their product isn't good enough.

What Ross meant by linux just working is that most distros include UAC1 and UAC2 drivers. But you will need to check your Linux distro to see what their support for USB audio classes is. Xmos has never developed a Linux USB audio class driver.
Eaque483
New User
Posts: 3
Joined: Wed Oct 11, 2017 10:38 am

Postby Eaque483 » Wed Oct 18, 2017 12:39 pm

Thank you very much for your help and support, i managed to connect my computer whithout a driver ! My apologies for taking your time !

Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 6 guests