auto_install.sh failing on stereo AVS kit

Technical discussions related to any XMOS development kit or reference design. Eg XK-1A, sliceKIT, etc.
seabrad
New User
Posts: 2
Joined: Fri Oct 05, 2018 1:54 pm

auto_install.sh failing on stereo AVS kit

Postby seabrad » Mon Nov 26, 2018 9:17 am

Hello,

I have recently re-installed stretch on my Rpi while troubleshooting issues with i2c control of the XVF3500.

Currently I am going back through the setup steps detailed in https://github.com/xmos/vocalfusion-stereo-avs-setup, which I have completed successfully on two previous occasions.

This time when executing the step #5 (run ./auto_install.sh) I receive the following output and error messages:

Code: Select all

pi@raspberrypi:~/vocalfusion-stereo-avs-setup $ ./auto_install.sh
Cloning into 'vocalfusion-rpi-setup'...
remote: Enumerating objects: 100, done.
remote: Total 100 (delta 0), reused 0 (delta 0), pack-reused 100
Receiving objects: 100% (100/100), 22.38 KiB | 0 bytes/s, done.
Resolving deltas: 100% (42/42), done.
Note: checking out '4a0701f17c119ecb0bf6f405591d25f0fe8f04be'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

  git checkout -b <new-branch-name>

Installing VocalFusion Stereo Raspberry Pi Setup...
Installing Raspberry Pi kernel headers
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  raspberrypi-kernel-headers
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 16.1 MB of archives.
After this operation, 104 MB of additional disk space will be used.
Err:1 http://archive.raspberrypi.org/debian stretch/main armhf raspberrypi-kernel-headers armhf 1.20181112-1
  Connection failed [IP: 2a00:1098:0:82:1000:13:0:5 80]
E: Failed to fetch http://archive.raspberrypi.org/debian/pool/main/r/raspberrypi-firmware/raspberrypi-kernel-headers_1.20181112-1_armhf.deb  Connection failed [IP: 2a00:1098:0:82:1000:13:0:5 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
make -C /lib/modules/4.14.79-v7+/build SUBDIRS=/home/pi/vocalfusion-stereo-avs-setup/vocalfusion-rpi-setup/loader modules
make[1]: *** /lib/modules/4.14.79-v7+/build: No such file or directory.  Stop.
Makefile:5: recipe for target 'default' failed
make: *** [default] Error 2
make -C /lib/modules/`uname -r`/build M=/home/pi/vocalfusion-stereo-avs-setup/vocalfusion-rpi-setup/i2c-gpio-param modules
make[1]: *** /lib/modules/4.14.79-v7+/build: No such file or directory.  Stop.
Makefile:6: recipe for target 'all' failed
make: *** [all] Error 2


Due to the errors indicating a failed connection I have added a (more) local mirroring site to my /etc/apt/sources.list file and am able to fetch other packages ... for instance step #2 in the guide works (sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel)

Not sure what else to do to ensure the issue is not with the connection on my side. As I said this has worked twice before.

Can anyone suggest next steps I might try?

thanks,

Brad

Who is online

Users browsing this forum: No registered users and 14 guests