X
RSS YouTube LinkedIn Twitter XCore IRC

Search




Post new topic Reply to topic   [ 3 posts ] 
Author Message
PostPosted: Tue May 17, 2011 10:20 am 
User avatar
XMOS Employee
Joined: Fri Dec 11, 2009 8:29 pm
Posts: 78
I've had quite a bit of feedback that that ap_ prefix for repository naming is confusing given that directories underneath have an app_ prefix.

Therefore, I propose that we change it to sw_.

This would affect the following repos:

ap_led_tile_controller
ap_pintest
ap_xscope_examples
ap_par_audio_dsp

These would become:

sw_led_tile_controller
sw_pintest
sw_xscope_examples
sw_par_audio_dsp

And everyone would have to change their local repos to point to the new names. If we want to do this it is best to do it now while there are hardly any of these. Any objections? If you own one of these repos and really don't want to change we can leave that repo.

Dave


Top
Offline Profile View all posts by this user  
 
PostPosted: Thu May 19, 2011 9:29 am 
User avatar
XMOS Employee
Joined: Fri Dec 11, 2009 8:29 pm
Posts: 78
Since no-one has objected I'm going to make this change so. I'll:

* Get the current ap_* repos maintained by xmos changed
* Update the community documentation

This just leaves ap_led_tile_controller which can be changed at interactive-matters discretion/leisure.

Dave


Top
Offline Profile View all posts by this user  
 
PostPosted: Thu May 19, 2011 10:07 am 
User avatar
XCore Addict
Joined: Wed Feb 10, 2010 10:26 am
Posts: 206
Hi,

I just had a lot to do last few days. I have changed ap_led_tile_control to sw_led_tile_control.

I think it is OK to sw for software instead of ap for application.

Thanks

Marcus


Top
Offline Profile View all posts by this user  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic   [ 3 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest



Search for:
Jump to: