Search found 95 matches

by CousinItt
Fri Jan 18, 2019 7:51 pm
Forum: Applications
Topic: XMOS and AKM DACs
Replies: 3
Views: 83

Re: XMOS and AKM DACs

Try using the glitch as a trigger and looking at the digital inputs to the DAC, the clocks in particular.
by CousinItt
Fri Jan 18, 2019 3:25 pm
Forum: Applications
Topic: XMOS and AKM DACs
Replies: 3
Views: 83

Re: XMOS and AKM DACs

Do you need to mute the AK4490 during a sample rate transition or reset the device first?
by CousinItt
Thu Jan 17, 2019 6:36 pm
Forum: Processors
Topic: USB and internal xlinks failing over time
Replies: 21
Views: 728

Re: USB and internal xlinks failing over time

Ed, can you clarify your remarks on X2D67, 68, 69, 70? I can see constraints for X2D07 etc. (presumably for unused boot pin circuitry) but not for X2D67 etc.
by CousinItt
Tue Jan 15, 2019 1:18 pm
Forum: Processors
Topic: USB and internal xlinks failing over time
Replies: 21
Views: 728

Re: USB and internal xlinks failing over time

Another wild idea: could the damage be done as the board is powered down? Is one rail staying up for a while without others, or without reset? Re the PLL cap. I haven't seen any ripple specs, but it would seem sensible to have it as close as possible. For the explorer kit, which uses the TQFP, the c...
by CousinItt
Fri Jan 11, 2019 1:22 pm
Forum: Processors
Topic: USB and internal xlinks failing over time
Replies: 21
Views: 728

Re: USB and internal xlinks failing over time

Hi Ed, this is a bit of a long shot, and I don't have any experience with the XU parts, but I've noticed that there seem to be at least two flavours of power sequencing guidelines in the XL/XU/XE data sheets. Some require both VDDIO/OTP_VCC to come up within 50ms of VDD, others require VDDIO and OTP...
by CousinItt
Thu Jan 10, 2019 7:23 pm
Forum: startKIT
Topic: Blue Pill for XMOS?
Replies: 4
Views: 1776

Re: Blue Pill for XMOS?

There have been such things: https://www.youtube.com/watch?v=-Wj8vBxFKy0

I'm not sure if anyone is doing something similar for the newer devices.
by CousinItt
Wed Dec 26, 2018 8:05 pm
Forum: Development Tools and Programming
Topic: Problem with gpio.h
Replies: 4
Views: 19198

Re: Problem with gpio.h

Have you tried doing a "clean project" before a "build project"? I've had similar problems and this often helps.
by CousinItt
Tue Dec 11, 2018 1:22 pm
Forum: Development Tools and Programming
Topic: lib_ethernet application on AN00199 example
Replies: 1
Views: 37453

Re: lib_ethernet application on AN00199 example

I'm not clear what you mean by "can't find the link" - I can see the call to rgmii_10_100_master_rx_pins in rgmii_ethernet_mac(). If you can't seen any changes in behaviour resulting from your mods, are you sure it's rebuilt correctly? It could be worth cleaning the ethernet library projec...
by CousinItt
Fri Dec 07, 2018 4:31 pm
Forum: Processors
Topic: Boot Modes for 3 x XL216 TQ128 design
Replies: 10
Views: 85419

Re: Boot Modes for 3 x XL216 TQ128 design

That's very useful - thanks for the update. I've looked for some more info and I can't find much. That snippet from the XN specification I quoted earlier refers to a line of devices, so clearly there should be some way in which it can work. The only other thing I've found is for the first generation...
by CousinItt
Fri Dec 07, 2018 4:09 pm
Forum: Processors
Topic: How to deal with USB pins on XL232 devices?
Replies: 7
Views: 82374

Re: How to deal with USB pins on XL232 devices?

Hi mon2 - sorry I missed your message. Thanks for the tip.

Still hoping someone from xmos might actually get around to answering this.