Page 2 of 2

Re: Acusis Linear Microphone Array Users

Posted: Wed Mar 07, 2018 3:41 am
by peterm
@wtip I do believe those are in fact set. It's worth a try getting the client to work.

To note I've had some troubles that I haven't debugged yet on that front. It happened when I updated my OS, so may be better now!

Re: Acusis Linear Microphone Array Users

Posted: Thu Mar 29, 2018 3:12 pm
by 2DogsAndADebugger
Hi Acusis Team,

Could you provide an update on the expected availability of an updated firmware to address the outstanding clipping issues?

Thanks!

2D&D

Re: Acusis Linear Microphone Array Users

Posted: Thu Mar 29, 2018 8:38 pm
by peterm
Hi 2D&D,

We have a new build that's almost ready, we should have a release by end of next week if not earlier!

Thanks,
Peter

Re: Acusis Linear Microphone Array Users

Posted: Wed Apr 04, 2018 7:47 pm
by peterm
Hi all,

We've tuned up a new version of the software. Please give it a try. If you have any questions please let us know.

Thanks!
Peter, on behalf of Andy (our tuning engineer)

==============================================

Link to software package
=====================

Just unzip the file below to get the files needed for the installation instructions below.
https://s3-us-west-1.amazonaws.com/acus ... .1.2.0.zip

Firmware Installation
=====================

There are 2 ways to install Acusis firmware updates, either via USB or the XTAG programmer

--- Updating via USB

Use the included 'xmosdfu' upgrade tool to load a new Acusis firmware image (e.g. Acusis_v1.1.2.0.bin). The upgrade tool is included for OSX and Linux (x86_64). A Windows version of the tool is in the works.

To use on Linux:

1. Open a terminal window and cd to this release directory.
2. cd host/Linux
3. sudo ./xmosdfu 0x11 --download ../../firmware/Acusis_v1.1.2.0.bin

To use on Mac:

1. Open a terminal window and cd to this release directory.
2. cd host/OSX
3. ./xmosdfu 0x11 --download ../../firmware/Acusis_v1.1.2.0.bin

On both platforms, you should see output similar to the following:

VID = 0x20b1, PID = 0x11, BCDDevice: 0x100
XMOS DFU application started - Interface 3 claimed
Detaching device from application mode.
Waiting for device to restart and enter DFU mode...
VID = 0x20b1, PID = 0x11, BCDDevice: 0x100
... DFU firmware upgrade device opened
... Downloading image (../../firmware/Acusis_v1.1.2.0.bin) to device
... Download complete
... Returning device to application mode

Afterward, you can verify that the upgrade was installed by running:

./xmosdfu --listdevices

Within the output, you should see the line:

VID = 0x20b1, PID = 0x11, BCDDevice: 0x1120

Where BCDDevice of 0x1120 indicates that v1.1.2.0 firmware is running.

--- Updating via XTAG

It's assumed that XTAG users have already installed the XMOS SDK and have the xflash tool available. To install, open a terminal window and locate the .xe image to install (e.g. Acusis_v1.1.2.0.xe). To install, run xflash:

xflash --no-compression Acusis_v1.1.2.0.xe

You may see a couple warnings with the following output at the end:

Site 0 has finished successfully.
==============================================

Re: Acusis Linear Microphone Array Users

Posted: Fri Apr 13, 2018 3:21 am
by wtip
I've successfully flashed the Acusis_v1.1.2.0.bin firmware from an Ubuntu 16.04 computer using the DFU update method.
I made a before and after recording and audio is much better! Now it's actually usable for my video chat application. This is awesome! Thanks for the update!

I just wanted to note that the crowdsupply update instructions don't actually include the s3 download link.
Also for some reason I didn't get any email notifications about the last 3 posts on this thread even though I'm watching it.

I haven't had time to do extensive testing but I think the microphone volume might be a little too low now. I have a logitech c910 and a ClearOne Chat 50 connected to this computer and with all microphone levels set to 100% volume the acusis volume is noticeably quieter than my other two mics. I was able to boost the volume past 100% on the acusis to match the levels and even so it was still noticeable how much less background noise the acusis was picking up so this doesn't really seem to be a problem.

Re: Acusis Linear Microphone Array Users

Posted: Sat May 26, 2018 12:06 am
by gladysw
We've just released an update to the firmware, v1.1.2.1. You can use either USB or XTAG programmer to perform the update.

Just unzip this file below for the latest release:
https://s3-us-west-1.amazonaws.com/acus ... .1.2.1.zip

Full release notes and install instructions are included in the zip.

Let us know if this helps with the volume issue some of you are having.

Thanks!
-Gladys

Re: Acusis Linear Microphone Array Users

Posted: Sat May 26, 2018 2:43 am
by wtip
Is it possible to downgrade back to v1.1.2.0 if I like it better than v1.1.2.1?

Re: Acusis Linear Microphone Array Users

Posted: Tue Jun 12, 2018 12:13 am
by andyw
wtip wrote:Is it possible to downgrade back to v1.1.2.0 if I like it better than v1.1.2.1?


Hi.

It's always possible to downgrade to an earlier version of the firmware if you want. The v1.1.2.0 firmware download link earlier in this thread is still active (which includes the v1.0 firmware as well).

-Andy