Compiler error message

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
JohnR
Experienced Member
Posts: 93
Joined: Fri Dec 11, 2009 1:39 pm

Compiler error message

Postby JohnR » Thu Mar 25, 2010 12:49 pm

Hi,

Yesterday I installed version 9.9.2 on a second laptop running XP Sp2, that has a very old version of the XMOS compiler, 8.11.2, also installed. The compiler on my usual machine is running fine.

Trying to compile, I get the error message

/c: can't open input file /c
xmake: ***[helloworld.o] Error 1.

I have two other XMOS projects in the same workspace and the same error message is emitted.
Both XMOS compilers emit the same error message. I reinstalled the compiler with the same result.

I checked the file permissions on the .xc files.

Any ideas?? I am sure that I am doing something stupid.

John.
User avatar
shawn
XCore Addict
Posts: 238
Joined: Thu Dec 17, 2009 5:15 am

Postby shawn » Fri Mar 26, 2010 2:43 am

Registry conflict perhaps, first see if old compiler is conflicting. "It is!"
Anyways I would uninstall booth and then just install 9.9.2.. If that
works fine, I wouldn't install the older version least you restore conflict.
I am not sure if that will solve said bug. Maybe someone here that has been
there would comment...

Who is online

Users browsing this forum: No registered users and 3 guests