Having trouble with XMOS IDE, Version: 11.11.1 (build 4707)

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
Posts: 30
Joined: Wed May 19, 2010 9:07 am

Having trouble with XMOS IDE, Version: 11.11.1 (build 4707)

Postby Lorien » Fri Jan 20, 2017 4:59 pm

I know it's an old IDE but I'm forced to use it to change one string! Te one which shows up when a product is plugged into the USB port. So, basically, instead of default "XMOS" string, I need to put a different one.
The problem is not there, the problem lies in eclipse at compilation runtime!
After running an old firmware (which I'm 100% sure it worked), now I got this message:

Code: Select all

"Updating eclipse config"
The system cannot execute the specified program.
xmake: *** [eclipse_config] Error 1

I have to admit that, a 10 minutes job ended up to be a 3 frustrating hours... digging into something that's "alien" to me and which should never be there in the first place! I kindly ask for anyone of you who's capable to source valid infos please do so!

Informations: I'm running Windows 10 Enterprise x64, version 1607, OS Build 14393.693
Java installed on my PC: version 8 update 121 (build 1.8.0_121-b13) - basically the latest version to this date that I'm aware off.

Additional notes:
* I don't have any other XMOS IDEs installed on this PC.
* I tried to move the workspace and the entire project on C:\workspace thinking that it might be a problem related to the file length. I even tried to remove the "space" and other special chars from the workspace path => Useless
* After importing my project in C:\workspace I clean it up and run it again => stuck on compilation with above error.
* I even deleted the .workspace directory inside the project directory but without any success.

Now I simply don't know what else should I do to convince this piece of software to run properly!

At some point I had the same issue but with xTimeComposer studio 14.x.x and I knew to change something in "xtimecomposer.ini" file but 11.11.1 doesn't have such a file to be changed!
So, being without any solution left to try I opened this thread hoping that I'll find what I'm looking for to continue my work.

Thank you for any help you'll provide!
Last edited by Lorien on Fri Jan 20, 2017 4:59 pm, edited 1 time in total.
Posts: 30
Joined: Wed May 19, 2010 9:07 am

Postby Lorien » Fri Jan 20, 2017 5:01 pm

I forgot to add the whole console content in case it's needed:

Code: Select all

**** Build of configuration XMOS Compiler Collection (xcc) for project app_usb_aud_l1 ****

xmake all
Creating dependencies for flash_programmer.h
Creating dependencies for flash_interface.h
Creating dependencies for dfu_types.h
Creating dependencies for dfu.h
Creating dependencies for usb_midi.h
Creating dependencies for midioutparse.h
Creating dependencies for midiinparse.h
Creating dependencies for midi_descriptor.h
Creating dependencies for SpdifReceive.h
Creating dependencies for SpdifTransmit.h
Creating dependencies for xc_ptr.h
Creating dependencies for usb_buffer.h
Creating dependencies for testct_byref.h
Creating dependencies for interrupt.h
Creating dependencies for decouple.h
Creating dependencies for audioports.h
Creating dependencies for pll.h
Creating dependencies for repeat.h
Creating dependencies for mixer.h
Creating dependencies for i2c.h
Creating dependencies for vendorrequests.h
Creating dependencies for endpoint0.h
Creating dependencies for descriptors_2.h
Creating dependencies for dbcalc.h
Creating dependencies for codec.h
Creating dependencies for clocking.h
Creating dependencies for audiostream.h
Creating dependencies for devicedefines.h
Creating dependencies for dbtable.h
Creating dependencies for clockcmds.h
Creating dependencies for audio.h
Creating dependencies for xud.h
Creating dependencies for usbaudio20.h
Creating dependencies for usb.h
Creating dependencies for hid.h
Creating dependencies for common.h
Creating dependencies for DescriptorRequests.h
Creating dependencies for port32A.h
Creating dependencies for lock.h
Creating dependencies for customdefines.h
Creating dependencies for SpdifReceive.S
Creating dependencies for fastmix.S
Creating dependencies for write_sswitch_reg_blind.S
Creating dependencies for XUD_EpFuncs.S
Creating dependencies for port32A.S
Creating dependencies for lock.S
Creating dependencies for flash_programmer.xc
Creating dependencies for dfu.xc
Creating dependencies for usb_midi_support.xc
Creating dependencies for usb_midi.xc
Creating dependencies for midioutparse.xc
Creating dependencies for midiinparse.xc
Creating dependencies for SpdifTransmit.xc
Creating dependencies for xuduser.xc
Creating dependencies for usb_buffer.xc
Creating dependencies for testct_byref.xc
Creating dependencies for decouple.xc
Creating dependencies for audioports.xc
Creating dependencies for mixer.xc
Creating dependencies for i2c.xc
Creating dependencies for endpoint0.xc
Creating dependencies for dbcalc.xc
Creating dependencies for audiorequests.xc
Creating dependencies for clockgen.xc
Creating dependencies for audio.xc
Creating dependencies for XUD_UIFM_Ports.xc
Creating dependencies for XUD_EpFunctions.xc
Creating dependencies for common.xc
Creating dependencies for DescriptorRequests.xc
Creating dependencies for hostactive.xc
Creating dependencies for audiostream.xc
Creating dependencies for codec.xc
Creating dependencies for clocking.xc
Creating dependencies for main.xc
Creating dependencies for flash_interface.c
Creating dependencies for get_adc_counts.c
Creating dependencies for reboot.c
Creating dependencies for l1_audio_flash_interface.c
"Updating eclipse config"
The system cannot execute the specified program.
xmake: *** [eclipse_config] Error 1
Respected Member
Posts: 346
Joined: Wed Jan 27, 2016 5:21 pm

Postby henk » Fri Jan 20, 2017 6:59 pm


Assuming you can copy it all to a safe area where you can play with it. Can you simply run make from the command line (in the 11.11.1 world)? You could try and remove the various .project files - you don't really need them I think.

Posts: 30
Joined: Wed May 19, 2010 9:07 am

Postby Lorien » Mon Jan 23, 2017 4:13 pm

Hello, thank you for input! Now I'm on the fourth day when I'm trying to solve this idiot problem without any valid results... other than a bunch of time spent for nothing.
It's really frustrating to need this piece of crap software running and seeing it's not doing so.
I don't have experience in playing with make apps in the command line since I usually work with the usual interface. So far I tried all kind of combinations I could think off, without any results:

1. Tried to revive my old Windows 7 OS which simply dies after an update was applied. There I knew this XMOS IDE worked so you can understand my struggle to make it work. Sadly no results (I couldn't revive it).
2. Installed a freshly Win 7 x86 OS + Java (latest version) + XMOS IDE 11.11.1 => useless.
3. Installed a freshly Win 7 x64 OS + Java (latest version) + XMOS IDE 11.11.1 => useless.
4. Installed a freshly Win 7 x86 OS + Java (version of 2013) + XMOS IDE 11.11.1 => useless.
5. Installed a freshly Win 7 x64 OS + Java (version of 2013) + XMOS IDE 11.11.1 => useless.
6. Installed a freshly Win 10 x64 OS + Java (latest version) + XMOS IDE 11.11.1 => useless.

I didn't go with x86 variant of Win 10 as, looking above I cannot see any reasons to do so...
7. I tried to remove the .Metadata directory from my project and import it again => useless
8. I even downloaded the XMOS default project from http://www.xmos.com and import it into my workspace (copy) to run it from there => useless.
9. Each time I compiled the project (regardless if it was mine or XMOS default) I did it directly by using the "build" option and, sawing that it's not working, I issues a project clean up first => useless.

So now I'm really pissed off since XMOS support is simply absent here and on their site I have to give my share to gather their attention. Perhaps there's someone here (from XMOS????) willing to help me in solving this stupid situation!

As I said, I'm not an expert but I have a strong feeling there's something going wrong with eclipse on my system, perhaps it has to be initialized? I don't know!

Kind regards, L

EDIT: forgot to mention that java versions were installed based on the OS: 32 bit for x86 and 64 bit for x64.

EDIT2: I also forgot to say that I've test this java + XMOS IDE bundle on my wife PC with the same crap result.
Posts: 30
Joined: Wed May 19, 2010 9:07 am

Postby Lorien » Mon Jan 23, 2017 5:11 pm

A bit of update: I managed to look into the ".log" file found in the workspace directory (C:/Users/user/workspace) and I found this:

Code: Select all

!SESSION 2017-01-23 18:06:29.814 -----------------------------------------------
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.core.resources 4 2 2017-01-23 18:08:35.003
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".
   at org.eclipse.cdt.internal.ui.buildconsole.BuildConsole.getBuildConsoleViewer(Unknown Source)
   at com.xmos.cdt.ui.TargetRefreshMonitor$2.resourceChanged(Unknown Source)
   at org.eclipse.core.internal.events.NotificationManager$2.run(NotificationManager.java:291)
   at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
   at org.eclipse.core.internal.events.NotificationManager.notify(NotificationManager.java:285)
   at org.eclipse.core.internal.events.NotificationManager.broadcastChanges(NotificationManager.java:149)
   at org.eclipse.core.internal.resources.Workspace.broadcastBuildEvent(Workspace.java:311)
   at org.eclipse.core.internal.resources.Project$1.run(Project.java:554)
   at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1975)
   at org.eclipse.core.internal.resources.Project.internalBuild(Project.java:524)
   at org.eclipse.core.internal.resources.Project.build(Project.java:115)
   at org.eclipse.ui.actions.BuildAction.invokeOperation(BuildAction.java:222)
   at org.eclipse.ui.actions.WorkspaceAction.execute(WorkspaceAction.java:162)
   at org.eclipse.ui.actions.WorkspaceAction$2.runInWorkspace(WorkspaceAction.java:483)
   at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
   at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".

It seems that there's definitely a eclipse problem but this is ahead of my limited skills on this matter. I'm still hoping that I'll get an answer here!
User avatar
XCore Expert
Posts: 768
Joined: Thu Dec 10, 2009 9:20 pm

Postby Ross » Tue Jan 24, 2017 12:15 pm

Could you build on the command line as a quick work around?
Posts: 30
Joined: Wed May 19, 2010 9:07 am

Postby Lorien » Tue Jan 24, 2017 1:42 pm

Hello Ross,
thank you very much for dropping by! Yesterday evening, after four stressful days I finally found the source of my problem: there was an issue with file "auto_proj.exe". In my project directory I had two of such files: "auto_proj.exe" and "auto_proj_000.exe". I guess the one with "_000" at the end was similar (if not identical) with the file found in original XMOS project downloaded from your site and, for reasons strange to me, there was another (new?) one called "auto_proj.exe" which simply issued the above errors at compiling level.
I simply don't have the required experience to explain why this happen but for the moment my frustration is over and I can continue my work stalled from Friday. Perhaps is because I tried to compile the same project with a newer XMOS IDE platform than 11.11.1? Now I learned on my own skin that I should never mix up projects with IDEs.

I hope it helps others to solve this kind of issues,
User avatar
Respected Member
Posts: 275
Joined: Fri Mar 12, 2010 6:03 pm

Postby larry » Tue Jan 24, 2017 6:12 pm

I'm sorry to hear that you are having trouble setting up the XMOS IDE.

My guess is that the USB audio software's projects haven't been imported correctly into the IDE. Is the software version definitely one that supports the old IDE version 11?

Note that you don't need the IDE to change a USB descriptor string. To compile, run:

Code: Select all

in the tools directory, then:

Code: Select all

xmake CONFIG=2ioxx
in the USB audio software directory (replace 2ioxx with configuration you are trying to build).
Posts: 30
Joined: Wed May 19, 2010 9:07 am

Postby Lorien » Wed Sep 05, 2018 8:49 pm

Yep, I'm reviving this thread again as I have other / similar issue with this App:

Code: Select all

**** Build of configuration XMOS Compiler Collection (xcc) for project app_usb_aud_l1 ****

xmake all
"Updating eclipse config"
Too many arguments in command line.
xmake: *** [eclipse_config] Error 1

Does anyone knows ow to solve this trouble?
I'm running W10 x64 Home edition on a 'very' capable PC, Java version 8 Update 181 (build 1.8.0_181-b13). xTime Composer 14.3.3 is running okay but this one is giving me a lot of troubles.
I tried to move the old XMOS project to C:\ and run it from there but it gives me the same error so I'm assuming is not from my (modified) project. System PATHs for Java were set in all kinds of ways but no luck.

Please help,
User avatar
XCore Legend
Posts: 1317
Joined: Thu Jun 10, 2010 11:43 am

Postby mon2 » Wed Sep 05, 2018 10:10 pm

Hi @Lorien.

1) Is this a project file you can post in the forum for testing? What is the history of this project? Have you modified the source in any way?

2) Can you attempt to download and re-install the latest JRE from Oracle? Also, select the 32 bit release.

Who is online

Users browsing this forum: No registered users and 96 guests