AVB EFU and xflash

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
Posts: 14
Joined: Mon Jan 30, 2017 11:09 am

AVB EFU and xflash

Postby tonetechnician » Fri Apr 13, 2018 2:17 pm

Hey everyone, I'm hoping someone can help me with this.

I'm currently trying to perform an EFU firmware update using the 1722.1 protocol and am running into some issues. We are using a custom board with a custom .xn file.

I have 3 .bin files I'm working with. I will name them one.bin, two.bin, three.bin.

one.bin and two.bin were created using xflash 14.3.2, the three.bin I'm unsure which xflash was used to create it (was created by someone else in our research group that I haven't been able to contact).

I've created one.bin and two.bin using the following command :

Code: Select all

xflash <binary>.xe -o <one/two>.bin

My issue is this:

I have xtag flashed one.bin onto the board using the correct .xn file. I believe this means that it is saved to the bootloader as the factory image and is hardware-protected.

From here I'm able to perform EFU using the three.bin file, and the one.bin file, but when I try perform EFU with the two.bin file, it defaults back to the one.bin file. Similarly, if I xtag flash the two.bin file, I'm able to perform EFU using the two.bin and three.bin but when I try with the one.bin, it defaults back to the two.bin file.

when I try xtag flash the three.bin file, the board does not work correctly and I'm not able to see it on my AVB network. This seems to me the three.bin file is not being saved as a factory image, or it wasn't created as a factory image.

What I've tried:

1. I've tried to create upgradeable binaries one.bin and two.bin using the command:

Code: Select all

xflash --factory-version 14.3 --upgrade 1 <binary >.xe -o <one/two>.bin

When I perform EFU using these .bins it stops the board from working and I need to xtag flash using a none upgrade image. I believe factory version flag is meant to be the xflash tools that the factory image .bin was created with.

2. I've tried xtag flashing these same upgradeable binaries and the board also does not work, so cannot do further testing.

Does anyone have any ideas as to why this behaviour occurs? I have a feeling I'm just not using the --upgrade command correctly, but am unsure where I'm going wrong

Thanks in advance!
User avatar
XCore Legend
Posts: 1350
Joined: Thu Jun 10, 2010 11:43 am

Postby mon2 » Fri Apr 13, 2018 4:23 pm

Image header format that may help:

User avatar
XCore Addict
Posts: 238
Joined: Thu Nov 26, 2015 11:47 pm

Postby akp » Sat Apr 14, 2018 12:56 am

You need to build two images for each release. The factory image you will xtag and use

Code: Select all

xflash <in_file>.xe -o <out_file>.bin

I am pretty sure you cannot xtag the EFU image.

The EFU image will be made with

Code: Select all

xflash --factory-version 14.3 --upgrade 1 <in_file>.xe -o <out_file>.bin

I believe you will need to use the correct factory-version based on what version of XMOS tools made the factory version (at least down to major version, e.g. 13 or 14)

Have you made sure you can EFU the MC Audio board with the unmodified XMOS TSN example (or with some trivial modification to the upgrade image to prove your upgrade took)?

Who is online

Users browsing this forum: No registered users and 2 guests