Code 52 with XMOS XS-1 U8 MFA

New to XMOS and XCore? Get started here.
Posts: 1
Joined: Mon Dec 31, 2018 2:39 am

Code 52 with XMOS XS-1 U8 MFA

Postby fitzgreen » Mon Dec 31, 2018 3:18 am

Forgive the newbie problem here, but I thought someone here would know the answer.

I just bought a new computer and it cannot "verify the digital signature for the drivers required for this device....(Code 52)". The software I have tried to install is Stereo-USB-Audio-Class2-Driver-2023_v3.34.0.exe, which came with the DAC. If I disable the signature verification, I can install it until a restart. The details show that the drive was digitally signed, but it is valid from 8/1/2015 to 8/1/2017. So, technically, it is no longer signed. Thing is, it worked fine on my old computer, running the same version of Windows 10 Pro, version 1809.

Questions: Does XMOS need to update its verification?
Is there a workaround for this?
Has anyone else encountered this?
User avatar
XCore Legend
Posts: 1749
Joined: Thu Jun 10, 2010 11:43 am

Postby mon2 » Wed Jan 02, 2019 3:34 pm

Hi. Not an audio developer but a developer of many other widgets for the PC industry...

1) You just applied a work around :)

2) It is possible that the old box works due to the OS being Windows 10 Pro but 32 bit? The 32 bit OS does not appear to demand the driver signing.

3) Your new box is Windows 10 64 bit so the driver must be vendor signed.

4) Once the driver is signed, you are ok to continue to use - do not worry about the "expiration date" - that is the certificate purchased by the vendor and was used to sign the driver. At one time, the certificate was current -> the vendor signed the driver code -> performed days of testing and submitted some cryptic logs to Microsoft -> Microsoft reviewed the results and then blessed the same driver code with their company signature. As a whole, the driver is then worthy of using on Windows 10.

Check with your hardware supplier if they offer a Microsoft signed 64 bit driver package for your Windows 10 use.

You can also try to review the "Secure Boot" option and turn it OFF. From my understanding that could be another work around:

(reference): ... and-later- ... d-drivers/

Who is online

Users browsing this forum: No registered users and 4 guests