ERROR: socket bind.(0)

If you have a simple question and just want an answer.
User avatar
aclassifier
Respected Member
Posts: 319
Joined: Wed Apr 25, 2012 8:52 pm
Contact:

ERROR: socket bind.(0)

Postby aclassifier » Fri Oct 02, 2015 5:01 pm

How do I get rid of this when I try to start debugging?

I have a startKIT. I have tried "everything". Some times debugging starts. 

xTIMEcomposer 14.0.4 but also 14.1.0. The latter I have given up at the time, and gone back tp 14.0.4. It seems like I took the socket binding error with me, because I haven't seen it before on 14.0.4.

I have OS X 10.10.5. JRE 1.8.0_51

I have shown some of it here.

User avatar
xmark
Member++
Posts: 19
Joined: Mon Apr 26, 2010 2:35 pm

Postby xmark » Tue Feb 16, 2016 5:42 pm

Hi,

I had this issue today for the first time. In my case, a reboot returned my machine to normality.

-Mark
User avatar
andrewxcav
Active Member
Posts: 61
Joined: Wed Feb 17, 2016 5:10 pm
Contact:

Postby andrewxcav » Wed Jul 06, 2016 8:25 pm

Same problem here on Fedora 23

Tools Version: Community_14.2.0 (build 11257, May-12-2016)

java version "1.8.0_77"

Rebooting fixed it as well.

Possibly relevant post about Java socket bind errors:

http://stackoverflow.com/questions/1085 ... bind-error
User avatar
infiniteimprobability
XCore Legend
Posts: 1119
Joined: Thu May 27, 2010 10:08 am
Contact:

Postby infiniteimprobability » Fri Dec 02, 2016 5:32 pm

Similar issue for me (first time ever after thousands of xruns..). However ps revealed xrun and xgdb hadn't terminated on ctrl-c. Killed those processes and all was well again..

Who is online

Users browsing this forum: No registered users and 134 guests