Stability Test

Technical discussions around xCORE processors (e.g. xcore-200 & xcore.ai).
ChrisDev
Member
Posts: 13
Joined: Tue Jan 31, 2017 8:45 am

Stability Test

Post by ChrisDev »

Hello everyone,

I'm currently experimenting with an XL216-Processor to reduce its power consumption.
One way I'm doing this, is to reduce the voltage it's working with.
Is there a known manner to test, if the processor can work stable? I was thinking of writing a short program to do some testing for several days and to check afterwards if any errors occurred.

Greetings,
Chris
plex
Member++
Posts: 22
Joined: Fri Aug 12, 2016 6:13 pm

Post by plex »

I can tell from personal experience that a core voltage bellow the specification of 0.95V will definitely create problems and I have seen here in this forum at least another case where a low voltage was creating intermittent errors.
ChrisDev
Member
Posts: 13
Joined: Tue Jan 31, 2017 8:45 am

Post by ChrisDev »

Could you specify the kind of problems?
And did you also reduce the system frequency or have you just lowered the voltage, in your personal case?

I'm asking this, because in a paper I've read they've used voltage and frequency scaling in order to achieve a lower power consumption.
plex
Member++
Posts: 22
Joined: Fri Aug 12, 2016 6:13 pm

Post by plex »

I did not do it on purpose. I had a problem with the switching regulator supplying the 1.0V and it was dropping to ~0.93V(with more ripple than it should have as well). The problems that I observed was in USB communications and debug communication which would only some times. The other problem that I read about occurred with errors in the ethernet communications if I remembered correctly.
User avatar
infiniteimprobability
Verified
XCore Legend
Posts: 1127
Joined: Thu May 27, 2010 10:08 am

Post by infiniteimprobability »

here's a link to the other case where low voltage was causing erratic behaviour

http://www.xcore.com/viewtopic.php?f=26&t=5787&p=29389