USB power/drivers on Win7 x64

Technical discussions related to any XMOS development kit or reference design. Eg XK-1A, sliceKIT, etc.
JamesHarrison
Newbie
Posts: 1
Joined: Fri Jan 22, 2010 1:31 pm

USB power/drivers on Win7 x64

Postby JamesHarrison » Mon Feb 01, 2010 10:59 am

Hi all,

I've just gotten hold of my XC-1A dev board and I can plug it into my Ubuntu netbook USB, have it boot up and the preloaded demos work fine. Being a netbook, the dev tools run criminally slowly so I can't really use it for development work. So I plugged it into my Windows 7 desktop, only to have the drivers fail to install, and the board appears not to get enough power to start up correctly.

I've tried 4 different USB ports on the machine, none of which work, the board shows up as a USB Composite Device but if I try and install drivers for it as specified in the manual, it doesn't work. Close inspection of the properties window in device manager shows a 'The device cannot start (10)' error.

I'm completely lost on how to fix this. Any suggestions would be greatly appreciated. If this is just a Windows 7 issue I can always run a copy of Windows XP 32-bit in a VM or something, but it looks a little lower-level than that...

Cheers,
James
User avatar
jonathan
Respected Member
Posts: 377
Joined: Thu Dec 10, 2009 6:07 pm

Postby jonathan » Tue Feb 02, 2010 7:12 pm

James - if you don't get any luck here, then please ping a ticket into XMOS (www.xmos.com/support).

This clearly shouldn't happen and I'm interested to know why.
Image
User avatar
leon_heller
XCore Expert
Posts: 546
Joined: Thu Dec 10, 2009 10:41 pm
Location: St. Leonards-on-Sea, E. Sussex, UK.

Postby leon_heller » Tue Feb 02, 2010 8:44 pm

FWIW, I didn't have any problems using the earlier XC-1 board with my new Dell laptop running Windows 7 64-bit.

I did have a problem with the XTAG-2 driver, but noticed that there were some updated drivers for it on the XMOS site and those worked OK.

Leon
User avatar
___
Member++
Posts: 30
Joined: Wed Feb 03, 2010 5:04 pm

Postby ___ » Wed Feb 03, 2010 5:05 pm

The XC-1A has been tested to work correctly on windows 7, in order for the device to function correctly you need to make sure you install the drivers from the drivers/ftdi directory in the installed development tools.

Who is online

Users browsing this forum: No registered users and 1 guest