SparkFun Development Kit

Technical discussions related to any XMOS development kit or reference design. Eg XK-1A, sliceKIT, etc.
User avatar
jonathan
Respected Member
Posts: 377
Joined: Thu Dec 10, 2009 6:07 pm

SparkFun Development Kit

Postby jonathan » Fri Dec 11, 2009 9:17 am

The SparkFun XMOS Development Kit recently had a large production run of 60-odd units, so these are now back in stock along with the XTAG2 programmers at Sparkfun:

http://www.sparkfun.com/commerce/produc ... ts_id=9428

Obviously if you have ideas for boards, post here or get in touch with SparkFun - and they might just happen...
Image
User avatar
Folknology
XCore Legend
Posts: 1274
Joined: Thu Dec 10, 2009 10:20 pm

Postby Folknology » Fri Dec 11, 2009 9:54 am

Do you know if they have fixed the earlier issues they had with uart pins being shared between the USB FTDI and the XSYS header?
They were talking about a new PCB, but the site still has the note about track cutting and possible scratches on the board.
Is there any side effects if the tracks are cut rather than fixed by a new PCB?

regards
Al
User avatar
jonathan
Respected Member
Posts: 377
Joined: Thu Dec 10, 2009 6:07 pm

Postby jonathan » Fri Dec 11, 2009 10:28 am

Folknology wrote:Do you know if they have fixed the earlier issues they had with uart pins being shared between the USB FTDI and the XSYS header?
They were talking about a new PCB, but the site still has the note about track cutting and possible scratches on the board.
Is there any side effects if the tracks are cut rather than fixed by a new PCB?

regards
Al
Our understanding is that they have simply cut the tracks (very discreetly) that caused the problem on this batch of boards. The boards should now program absolutely as they were intended to. The boards have been tested working with the fix.

They've sold quite a few (must be 30+ now) and some of the users have applied the fix themselves. No reported problems yet!
Image
User avatar
leon_heller
XCore Expert
Posts: 546
Joined: Thu Dec 10, 2009 10:41 pm
Location: St. Leonards-on-Sea, E. Sussex, UK.

Postby leon_heller » Fri Dec 11, 2009 1:15 pm

I've modded both of my boards, and it's fixed the problems. I've ordered two of the "scratched" boards.

Leon
User avatar
mio
Member
Posts: 13
Joined: Fri Dec 11, 2009 6:14 am
Location: Japan

Postby mio » Fri Dec 11, 2009 4:48 pm

Hello,
I also bought it (was written at xmoslinkers).

The stock revived again.
But SFE says in the mail to me,
The latest build posted on the web page has these traces already cut.
There will be a revision in that fixes this problem within the next
month and a half.
I will do an additional order by the $100 campaign at 1/7.
However, the correction doesn't seem to be in time :(
mio / a.k.a. yu-pi-te-ru at http://moxi.jp/
User avatar
jonathan
Respected Member
Posts: 377
Joined: Thu Dec 10, 2009 6:07 pm

Postby jonathan » Tue Dec 15, 2009 12:58 pm

http://www.watterott.com/XMOS

Seem to be a SparkFun distributor in Europe. Could prove handy for some people. They are selling the SparkFun board and the XTAG-2 in Euros.
Image
User avatar
leon_heller
XCore Expert
Posts: 546
Joined: Thu Dec 10, 2009 10:41 pm
Location: St. Leonards-on-Sea, E. Sussex, UK.

Postby leon_heller » Tue Dec 15, 2009 2:24 pm

My two "scratched" boards have just been delivered. They haven't done it very neatly, but they work OK. I ordered them direct from SFE with Fedex delivery.

Leon
User avatar
TonyD
XCore Addict
Posts: 234
Joined: Thu Dec 10, 2009 11:11 pm
Location: Newcastle, UK

Postby TonyD » Wed Dec 16, 2009 10:44 am

jonathan wrote:http://www.watterott.com/XMOS

Seem to be a SparkFun distributor in Europe. Could prove handy for some people. They are selling the SparkFun board and the XTAG-2 in Euros.
Thats good news - I hope the other Sparkfun distributors start stocking it as well.
User avatar
TonyD
XCore Addict
Posts: 234
Joined: Thu Dec 10, 2009 11:11 pm
Location: Newcastle, UK

Postby TonyD » Fri Dec 18, 2009 9:56 am

Little Bird Electronics of Australia and
warf.com of Thailand are also stocking the Sparkfun board.
nagmier
Member++
Posts: 21
Joined: Fri Dec 11, 2009 3:42 pm

Postby nagmier » Fri Dec 18, 2009 2:04 pm

I noticed that there is an XSYS connector on this board...would it be possible to get this board to communicate over xlinks with the xk-1? I have been looking into purchasing another xk-1 but this might be the ticket any ideas? I may just have to try it out if noone knows.

Who is online

Users browsing this forum: No registered users and 2 guests