AN00152 bidirectional xscope

Technical discussions related to any XMOS development kit or reference design. Eg XK-1A, sliceKIT, etc.
klausbusse
Member
Posts: 11
Joined: Thu Jan 10, 2013 11:28 pm

AN00152 bidirectional xscope

Postby klausbusse » Fri Apr 22, 2016 3:00 pm

I need some help.

I would like to use the AN00152 but it does not work after download via xTIMEcomposer.

On my Host PC is Win 8.1 running.

If I am starting with Project>Build Project - I got 1 Error: fatal error: 'simplefs.h' file not found

If I am starting Host>Win32 xscope_host_console.exe I got error xscope _endpoint.dll missing in the Host PC.

Any Idea's?
User avatar
Thomas
Experienced Member
Posts: 66
Joined: Fri Feb 05, 2010 12:34 pm

Postby Thomas » Fri Apr 22, 2016 4:17 pm

Hi Klaus
Please make sure that you're using the latest tools release 14.1.2.
Then you can import the AN00152 directly from the xTIMEcomposer GUI:
- click on Examples then search for xscope.
- Double click xSCOPE - Bi-Directional Endpoint
- Build and run.

On the host side:
Make sure that the tools are installed in your shell where you compile.
See chapter 3.2 Start the command-linetools
https://www.xmos.com/download/private/x ... 4.x%29.pdf

Best Regards, Thomas
klausbusse
Member
Posts: 11
Joined: Thu Jan 10, 2013 11:28 pm

Postby klausbusse » Tue Apr 26, 2016 12:09 am

Thanks. Problems are solved. Now I can exchange data between PC and XCORE-200-EXPLORER Board in both Direction.


Now an other question: When I transmit from PC a string with 1024+1 octet. The string wil be splitted by xscope_data_from_host like:

1. 256 octets
2. 256 octets
3. 256 octets
4. 256 octets
5 1 octet

Is there any posibility to configure no spliting e.g no fragmenting between PC and Device in both direction.

see AN00152...


char data[1024];
PC Host function: xscope_ep_request_upload(strlen(data)+1, (const unsigned char *)data);

XCORE-200-EXPLORER: case xscope_data_from_host(xscope_data_in, rxbuf, bytesRead):
peter
XCore Addict
Posts: 230
Joined: Wed Mar 10, 2010 12:46 pm

Postby peter » Tue Apr 26, 2016 12:22 pm

Unfortunately, due to the way the xSCOPE connection has currently been implemented it will fragment the data into 256 byte chunks. You should be able to very easily implement your own protocol on top of xSCOPE to do what you want. For example, send a length word first and then follow it with the data that you can place into a large buffer before passing it to the application.
klausbusse
Member
Posts: 11
Joined: Thu Jan 10, 2013 11:28 pm

Postby klausbusse » Tue Apr 26, 2016 2:10 pm

OK. Many Thanks.
I will implement a header and a protocol as proposed. At the moment the last fragment of the data stream triggers the problem.
monsonite
Newbie
Posts: 1
Joined: Thu May 26, 2016 10:49 pm

Postby monsonite » Thu May 26, 2016 10:57 pm

Hi,

I have exactly the same problem as Klaus.

Using xTimecomposer Version: Community_14.2.0 (build 11257, May-12-2016)

Downloaded xscope example AN00152

Trying to run xscope_host_console.exe under Win 8 - complains that xscope_endpoint.dll is missing from computer.

Does the host code have to be recompiled to generate this dll ?

How exactly do I fix this please?


TIA


Ken
peter
XCore Addict
Posts: 230
Joined: Wed Mar 10, 2010 12:46 pm

Postby peter » Tue May 31, 2016 8:45 am

You need to ensure that you are running the xscope_host_console.exe in a xTIME Composer Command Prompt (icon should have been added to your desktop on installation), otherwise the path will not be set up so that the xscope_endpoint.dll can be found.

Who is online

Users browsing this forum: No registered users and 1 guest