XFLASH -o Option not Saving to File Topic is solved

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
RitchRock
Experienced Member
Posts: 118
Joined: Tue Jan 17, 2017 9:25 pm

XFLASH -o Option not Saving to File

Postby RitchRock » Mon Apr 15, 2019 8:08 pm

Trying to save to file using XFlash command:

Code: Select all

xflash program.xe -o image-file
But Xflash ends with "problem connecting to device". Isn't the -o option suppose to output to file? Is my command formatted incorrectly?

Here is the --verbose output:

Code: Select all

XFlash_Application found _start :40000 on Node 0
XFlash_Application found _DoSyscall :46610 on Node 0
XFlash_Application found _DoException :400a4 on Node 0
XFlash_Application found _start :40000 on Node 0
XFlash_Application found _DoSyscall :48924 on Node 0
XFlash_Application found _DoException :400a4 on Node 0
XFlash_Application : Attempting to Compress Binary Data
libcompressor marker 1=155
libcompressor marker 2=218
libcompressor marker 3=246
libcompressor best marker length 3 2 2
libcompressor best marker length 3 2 3
libcompressor best marker length 3 2 4
libcompressor best marker length 4 2 3
libcompressor best marker length 4 2 4
libcompressor best marker length 5 2 4
libcompressor best marker length 6 2 4
libcompressor best marker length 7 3 4
libcompressor DoCompression_Compress took : 23645ms
libcompressor compile command=xcc -nostartfiles -Xmapper --bootstyle=forsim -x assembler-with-cpp "decompressor-5a8a22ef" -x xn "target-xn-v0-9b4715b6" -o decompressor-649b9b25
libcompressor validating decompressor decompressor-649b9b25
libcompressor launching simulator decompressor-649b9b25 --disable-syscalls --max-cycles 100000000
libcompressor simulator starting @0x40000
libcompressor simulator terminate @0x7ff58
libcompressor decompressor validated
XFlash_Application on Node : 0 compressed from : 57104 bytes to : 34000 bytes (40.46%)
libcompressor marker 1=107
libcompressor marker 2=246
libcompressor marker 3=126
libcompressor best marker length 3 2 2
libcompressor best marker length 3 2 3
libcompressor best marker length 3 2 4
libcompressor best marker length 4 2 4
libcompressor DoCompression_Compress took : 1797ms
libcompressor compile command=xcc -nostartfiles -Xmapper --bootstyle=forsim -x assembler-with-cpp "decompressor-0d49ea7c" -x xn "target-xn-v0-9b4715b6" -o decompressor-3bc2f8ef
libcompressor validating decompressor decompressor-3bc2f8ef
libcompressor launching simulator decompressor-3bc2f8ef --disable-syscalls --max-cycles 100000000
libcompressor simulator starting @0x40000
libcompressor simulator terminate @0x7ff58
libcompressor decompressor validated
XFlash_Application on Node : 0 compressed from : 50048 bytes to : 34160 bytes (31.75%)
XFlash::DoXFlash
XFlash::DoImageProgramming
XFlash::GetDeviceInfo
XFlash_DeviceInfo::GetDeviceInfo_Hardware
XFlash_DeviceInfo::GetDeviceInfo_Hardware_IssueCompileCommand : xcc -Xmapper --dontenablesodlinks -Xmapper --wnoXN -x xc "spiinfo-0fd69a7b" -x xn "target-xn-v0-9b4715b6" -o "spiinfo-aabdcc4a" -lquadflash -D xnPORT_SQI_CS0=PORT_SQI_CS -D xnPORT_SQI_SCLK0=PORT_SQI_SCLK -D xnPORT_SQI_SIO0=PORT_SQI_SIO
XFlash_Utils::BuildRunCommand : xrun --io spiinfo-aabdcc4a
xrun: Problem in connection to device
View Solution
RitchRock
Experienced Member
Posts: 118
Joined: Tue Jan 17, 2017 9:25 pm

Postby RitchRock » Mon Apr 15, 2019 8:15 pm

To add, if I use the "output to file" option in the IDE, instead of command line tools, I get "xrun: Problem in connection to device". I'm on Windows 10.
RitchRock
Experienced Member
Posts: 118
Joined: Tue Jan 17, 2017 9:25 pm

Postby RitchRock » Mon Apr 15, 2019 10:40 pm

It works if the device is attached - I figured that since I was writing to a file this didn't need to be the case.
bearcat
Respected Member
Posts: 271
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Tue Apr 16, 2019 5:27 am

Try using the --noinq option for xflash.

Who is online

Users browsing this forum: No registered users and 1 guest