What is '_Sxtcp_connect_0' in UDP application?

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
jsgn3
Member
Posts: 9
Joined: Tue Jan 07, 2020 4:10 pm

What is '_Sxtcp_connect_0' in UDP application?

Postby jsgn3 » Mon Jan 13, 2020 5:03 pm

I am developing a UDP application with uses amongst other
the library lib_xtcp (4.0.1). When I compile the program
this call causes an error:

---
xtcp_connect(c_xtcp,
BROADCAST_PORT,
broadcast_addr,
XTCP_PROTOCOL_UDP);
---

The error is:

---
Compiling tcp_reflect.xc
Rebuild .build/_obj.rsp
Creating Gigabit.xe
../src/tcp_reflect.xc: Error: Undefined reference to '_Sxtcp_connect_0'
---

I have no single clue about what ''_Sxtcp_connect_0" is. I found it nowhere
in the software, libraries or on the internet, for that matter.

Any idea what ''_Sxtcp_connect_0" is and how to solve this error?
User avatar
akp
Respected Member
Posts: 428
Joined: Thu Nov 26, 2015 11:47 pm

Postby akp » Tue Jan 14, 2020 3:14 pm

Did you clean the project prior to build? Errors like this can show up if you don't.
jsgn3
Member
Posts: 9
Joined: Tue Jan 07, 2020 4:10 pm

Postby jsgn3 » Thu Jan 16, 2020 8:53 am

Yes, I did.
User avatar
CousinItt
XCore Addict
Posts: 176
Joined: Wed May 31, 2017 6:55 pm

Postby CousinItt » Thu Jan 16, 2020 12:09 pm

Note the current revision of lib_xtcp is 6.0.0. Have you included a link to the library in your makefile?
jsgn3
Member
Posts: 9
Joined: Tue Jan 07, 2020 4:10 pm

Postby jsgn3 » Mon Jan 20, 2020 11:20 am

CousinItt wrote:
Thu Jan 16, 2020 12:09 pm
Note the current revision of lib_xtcp is 6.0.0. Have you included a link to the library in your makefile?
I used an example which needs 4.0.1. So I do not link to 6.0.0.

Because of the problems we have with all this we decided to go
for an FPGA.

Who is online

Users browsing this forum: No registered users and 4 guests