xTIMEcomposer 14.2.4 on macOS 10.12 Sierra?

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
User avatar
aclassifier
Respected Member
Posts: 332
Joined: Wed Apr 25, 2012 8:52 pm

xTIMEcomposer 14.2.4 on macOS 10.12 Sierra?

Postby aclassifier » Sun Jan 15, 2017 11:24 pm

Is there any risk installing xTIMEcomposer 14.2.4 on macOS (OS X) 10.12 Sierra?

If no problem, why hasn't the Requirements list been updated? (It's called "macOS" now)

And the present JRE, it says "1.6 or later" (with no revert to older version if I get a newer JRE?)
henk
Respected Member
Posts: 346
Joined: Wed Jan 27, 2016 5:21 pm

Postby henk » Thu Jan 19, 2017 11:20 am

Hi,

I have just upgraded, and I had to install 'legacy java' (Sierra said 'Install this', and I did, and it worked - xSCOPE that is, I haven't tried the rest of the IDE)

Cheers,
Henk
User avatar
aclassifier
Respected Member
Posts: 332
Joined: Wed Apr 25, 2012 8:52 pm

Postby aclassifier » Mon Jan 23, 2017 8:09 am

Ok. Do you know whether XMOS has any plans to go mainstream Java?

And, which component is it that now requires "legacy" Java? Eclipse, xScope etc?
henk
Respected Member
Posts: 346
Joined: Wed Jan 27, 2016 5:21 pm

Postby henk » Mon Jan 23, 2017 7:20 pm

It'll be eclipse.

I guess that the problem with going mainstream is that you suddenly no longer support older versions?
User avatar
aclassifier
Respected Member
Posts: 332
Joined: Wed Apr 25, 2012 8:52 pm

Postby aclassifier » Tue Jan 24, 2017 1:01 pm

xTIMEcomposer 14.2.4 (1) now has "Update from eclipse base version 3.6 --> 4.3" and "Integration with eclipse marketplace for installing 3rd party software". That's great, but 4.3 is still seen as an "old version" from June 2013 (2). Going further into the next Eclipse release would have brought Java 8 with it. So it says. Would this have helped?

Or is it the XMOS plug-ins that would require older Java?

I thought that the Java infrastructure was rather good on backwards/forwards compability, I believe by just requiring JRE to be updated to the newest - that was runnable on virtually all old systems?

(1) https://www.xmos.com/download/private/T ... 4.2.4).txt

(2) https://en.wikipedia.org/wiki/Eclipse_(software)

Who is online

Users browsing this forum: No registered users and 1 guest