read device firmware

New to XMOS and XCore? Get started here.
willem_vdk
New User
Posts: 2
Joined: Fri Feb 01, 2019 11:11 pm

read device firmware

Postby willem_vdk » Mon Feb 25, 2019 6:00 pm

Hi all,

I have been trying to read the device firmware that comes pre-installed on the Xcore-200 MC Audio board using the XTAG3 programmer.
From what I understand using xflash enables you to read the binary file with a command like
"xflash --read-all -o device_firmare_dump.bin --target XE216-512-TQ128-C20"
this outputs

Warning: XN11135 Attribute SystemFrequency is ignored when Oscillator is not specified.
Warning: XN11206 Oscillator is not specified for USB node.
Error: F03040 Platform definition (XN) does not specify a boot flash device.

which makes sense, so I tried using the target-file option which I presumed is the .xn file, i tried the .xn file that comes with the example firmware
xflash --read-all -o out.bin --target-file xk-audio-216-mc.xn
this outputs

Error: Failed to recognise flash device at node "0".
xrun: Program received signal ET_LOAD_STORE, Memory access exception.
0x000408cc in fl_getPageSize ()
Error: F03013 Failed to run : 008FEA48.

has anyone tried reading the firmware?
thanks in advance!
User avatar
mon2
XCore Legend
Posts: 1348
Joined: Thu Jun 10, 2010 11:43 am

Postby mon2 » Mon Feb 25, 2019 9:54 pm

Can you repeat your attempt but add --verbose to the command line and post your output?

Who is online

Users browsing this forum: No registered users and 0 guests