xFlash taking forever to program

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
Respected Member
Posts: 277
Joined: Fri Mar 19, 2010 4:49 am

xFlash taking forever to program

Postby bearcat » Thu Jan 08, 2015 8:31 pm

I am seeing xFlash taking on the order of 5 minutes to flash my projects. Tried multiple boards and designs, all taking very long. No errors are thown and it completes successfully.

Using Community 13.2.0 on vista. Had no problems in the past versions like this. I have not loaded 13.1 again to see if xFlash returns to normal. So I am not saying I know it is a version problem, yet. Nor have I tried a reference design, yet.

User avatar
XCore Legend
Posts: 1124
Joined: Thu May 27, 2010 10:08 am

Postby infiniteimprobability » Fri Jan 09, 2015 8:56 am

That is strange...

As you know xflash does a lot when invoked - it generates a flash programming source file, builds it, loads it onto the target. Then it takes the .xe file, and strips/splits it to get the actual raw binaries. Also, it generates the stage 2 loader, builds that and makes a binary. These files are then combined into a single binary which is the flash image. (Obviously there is even more to it when DFU is used as it needs to manage multiple images and boot steering).
It then erases the flash and then communicates over USB<->JTAG to the target with data blocks which are programmed into the flash and then verified.

I would be surprised if the tools stuff was taking very long, especially if your compilation speed seems normal. You can test this by doing:

Code: Select all

xflash --save-temps  my_app.xe
You can then look at the date codes of the various files. Actually, do have a look at these files too - it's quite interesting to see what pops out.

If this is all Ok, it leaves the actual flash programming bit. The flash programming task reports back over JTAG print to the console it's progress. How quickly are the "write" and "verified" addresses coming up on screen? Is this bit obviously slow?

If so, it's either host comms or flash programming speed. It's probably not an individual flash thing (slow flash) if you tried on lots of different boards.

Have you noticed JTAG loading (or printing to the console from an app without xscope) slow? If not that would leave flash programming speed.

My gut suggests host a comms issue though..
Respected Member
Posts: 277
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Fri Jan 09, 2015 5:56 pm

Thanks for the reply. Tested the --save-temps. See below:
Files were generated quickly, so probably not a build issue. Here's the command window:
xFlash gets to the last xmap warning in about 5 seconds. Ok.
Takes several minutes to get from that last warning to the write verify part. When it starts writing, it completes in a couple seconds (speed writing seems as fast as before problem). I had tried a write binary command (no build) and took similar time. Using a USB2 port.

When debugging it seems reasonable. But sometimes when a breakpoint is hit, it can take a few seconds to populate all the cores in the GUI. Maybe slower than I remember from before.

I do have a second XTAG2 I will try. Eventually will load 13.1 and give that a try. Eventually will try another computer.

Does maybe seem to be a comms issue starting up the flash program in the tile. Tried a board I know worked ok before along with a couple others.
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 3 guests