XU208-128-TQ64 : Problem SPI Flash

Technical discussions around xCORE processors (e.g. xcore-200 & xcore.ai).
Posts: 8
Joined: Tue Nov 21, 2017 2:17 pm
Location: France

XU208-128-TQ64 : Problem SPI Flash

Post by xP0W3R »

Hi everyone,

I encountered a problem when I wanted to program my s/w into the flash.
Command Prompt indicated that :

Code: Select all

C:\Users\xxx>xflash usb_aud_XU208.xe
Error on tile[0]: failed to connect to flash device. Please verify that SPI type is supported and that the correct SPI ports are defined within your xn file.
I did verify and everything seems good, I don't know where the problem could be...
Here is my xn file and makefile.

If anyone has an idea where the problem is, may be the flash itself ?
The SPI Flash I use is : AT25SF041-SSHD-T
You do not have the required permissions to view the files attached to this post.
User avatar
XCore Legend
Posts: 1913
Joined: Thu Jun 10, 2010 11:43 am

Post by mon2 »

may be the flash itself ?

The posted XN file is referencing the flash p/n AT25FS010 but you are using AT25SF041-SSHD-T

Code: Select all

    <Device NodeId="0" Tile="0" Class="SPIFlash" Name="bootFlash" Type="AT25FS010">
During the flash program phase of the XMOS tools, the programmer will ping your flash device and send out a standard SPI command -> extract the ID from the physical device and compare to the IDs stored on file that you are referencing in the XN file. So, there will be an ID mismatch in your case.

You have some options:

1) you can swap out the flash you have with the AT25FS010 but that component appears to be NRND (EOL).

2) alter the look up table for the AT25FS010 to reflect the true geometry of the device you are actually using (recommended).

Review the definition of the AT25FS010 and compare this to the AT25FS041 -> upgrade to the IDs inside your flash device -> increase the # of sectors to match, ideally use a flash device that configures the QSPI mode of the flash in the same manner as the original flash supported by the XMOS tool, etc. The XCORE-200 series of processors like the one you are using, boot using QSPI mode so you must be sure that your flash device is capable of this feature. Not all flash devices enable QSPI in the same manner (sometimes different register and bit locations). Try again. The XFLASH tool offers details on this process. The definition of the flash device is stored inside a text (ASCII) file.

Based on the excellent factory support received from ISSI (USA) on a recent XMOS issue, recommend that you consider the ISSI brand:


If after the above compliance, you are still facing issues, please post more details on your hardware with partial relevant schematics of the CPU and power supply, etc.
Active Member
Posts: 48
Joined: Mon Oct 19, 2015 2:12 pm

Post by matthew1 »


have you tried creating a custom spi spec file for this flash? Take a look at this:

https://www.xmos.com/support/tools/docu ... ion=latest

xflash can then be run with the --spi-spec option.


Posts: 8
Joined: Tue Nov 21, 2017 2:17 pm
Location: France

Post by xP0W3R »

Hi I'm back,

I had to wait that Windows does an update to solve my problem of driver.

So, I can program the software into the flash but it doesn't want to run.
I use now as flash SST25VF010A-33-4I-SAE. The flash might be too small ?
I tried to porting from the xu216's software and lastly this version http://www.xcore.com/viewtopic.php?t=6375