SD card library example is not working.

First time on the site? Say hello here!
jems
Member
Posts: 9
Joined: Tue Jun 25, 2019 1:23 pm

SD card library example is not working.

Postby jems » Thu Jul 11, 2019 12:02 pm

Hello !!!
Guys, I want to use the SD card for reading data.
Mainly, This SD card connected to xmos StartKIT.
So,Please share me code for use this sd card into my device.
I already try to use library which given by,
https://github.com/xcore/sc_sdcard
But depended library to many even after fill still show error on it.
Pls help me out this problem.
Thank you.
jems
Member
Posts: 9
Joined: Tue Jun 25, 2019 1:23 pm

Postby jems » Tue Jul 30, 2019 6:10 am

Pls help for this problem.
I hope any one reply me.
Thank you.
User avatar
mon2
XCore Legend
Posts: 1560
Joined: Thu Jun 10, 2010 11:43 am

Postby mon2 » Mon Aug 05, 2019 9:33 pm

Hi. Sorry, missed this post earlier...try the following:

1) Start with a fresh workspace

2) Select Edit perspective (left side of the screen) -> File (top bar menu) -> Create New xTimeComposer Project -> Select a project name of your choice -> Select the startKIT as your Target Hardware -> remove the check so that the Empty xC file is NOT created -> Finish. Leave this tool open.

3) Download from the SD card github sit you are referencing the entire project as a Zip file -> Select Clone or Download -> Download ZIP

4) Back to your xTimeComposer -> File -> Import -> Archive File -> locate with your browser the downloaded zipped file for the SD card from github. This tool will now import this project into your workspace.

5) Proceed to compile using -> Select the project name you selected at the top of this project tree -> Project -> Clean -> Build all. If all goes well, you should have a binary file generated with the .xe suffix.

Hope this helps. Post back if you have issues.

Good luck!

Who is online

Users browsing this forum: No registered users and 0 guests