How to erase/reset xCORE-200 (XE216-512-TQ128)

Technical discussions related to any XMOS development kit or reference design. Eg XK-1A, sliceKIT, etc.
Junior Member
Posts: 4
Joined: Tue Jun 29, 2021 10:56 pm

How to erase/reset xCORE-200 (XE216-512-TQ128)

Post by ColdKeyboard »

Hi everyone,

I have a board with XE216-512-TQ128 on it. This board is essentially a copy-paste design of a xCORE-200 eXplorerKIT wit few additional components.

I used the board for a couple of day and it was working fine, I'm able to xrun and xflash the new firmware.
However today I noticed that no matter what, board seems to be running an older version of FW that I can not overwrite.

First I tried running `xrun binary-file` then I tried `xflash binary-file` and both of them pass. However after reset board continues to run old firmware.
I also tried running `xflash --erase-all --target-file xk-audio-216-mc.xn` and it passes, however it still runs old firmware.

I'm a total newbie so I would appreciate any help on how to "reset" or "restore" XE216 so I can run firmware with `xrun`.
Thank you in advance!
User avatar
Experienced Member
Posts: 111
Joined: Sun Mar 06, 2011 11:39 pm

Post by TSC »

Just as a sanity check, are you sure your binary file *project*.xe is actually being built? Check the date modified on that file.

Is this a board you designed yourself?
Junior Member
Posts: 4
Joined: Tue Jun 29, 2021 10:56 pm

Post by ColdKeyboard »

I did confirm that code is being built. I also did `xmake clean` and then `xmake` afterwards.

I guess my question is how do I completely erase the device (reset it to how it would be out of the box)?

This is the board I designed myself but basically just copied everything from the eval board minus the ethernet connector and few other features that I'm not using.
Again, this board was working fine for a while and when I program it, it was working, when I power cycle it it would be blank or if I do erase it would also behave like it's blank.
Now after couple of days of xrun/power-cycle, xrun/xflash has no effect on the board.

Maybe interesting piece of information; Last firmware had a LED that it turns on to indicate it has booted. Usually after power-cycle device would be "blank" I would have to xrun the code again to get it to work. Which makes sense and is desired behavior.
Now as soon as it powers up it's running some old version of firmware that I'm not able to overwrite with xrun/xflash. Having a way to nuke everything and reset it to a factory default would be a great amazing. :)

p.s. I'm pretty confident that I didn't accidentally OTP the chip or lock it but if anyone suspects that, let me know how I can check for that and I'll attach the printout here.
User avatar
XCore Legend
Posts: 1913
Joined: Thu Jun 10, 2010 11:43 am

Post by mon2 »


Code: Select all

./xflash --verbose --erase-all  ; and post your verbose output
It appears your flash is running the FACTORY image of your firmware = your first known good image.